Introduction

This handout was created to familiarize the user with the most common functions in Excel.

Using Formulas

Formulas and function are mathematical statements used to perform calculations.

- A formula is an instruction made up by the user to perform a specific calculation.
- All formulas must start with an equal sign and contain cell addresses, numbers, and mathematical operators.
- When preparing a formula it is important to consider the order of mathematical operations. A formula that has more than one operation follows an order of precedence.

The order is as follows from left to right:
1. Exponentiation
2. Multiplication
3. Division
4. Addition
5. Subtraction

Note: If a formula has parenthesis, the operation(s) in the parenthesis is performed first. Remember to use the math acronym **Please Excuse My Dear Aunt Sally** to assist with the order of operations.

Example:

<table>
<thead>
<tr>
<th>Operator</th>
<th>Meaning</th>
<th>Example</th>
<th>Result (if A1=18 &amp; A2 = 2)</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Addition</td>
<td>=A1+A2</td>
<td>20</td>
</tr>
<tr>
<td>-</td>
<td>Subtraction</td>
<td>=A1-A2</td>
<td>16</td>
</tr>
<tr>
<td>*</td>
<td>Multiplication</td>
<td>=A1*A2</td>
<td>36</td>
</tr>
<tr>
<td>/</td>
<td>Division</td>
<td>=A1/A2</td>
<td>9</td>
</tr>
<tr>
<td>%</td>
<td>Percentage</td>
<td>=A1%A2</td>
<td>.18</td>
</tr>
<tr>
<td>^</td>
<td>Exponentiation</td>
<td>=A1^A2</td>
<td>324</td>
</tr>
</tbody>
</table>

Exercise 1

1. Create the worksheet listed shown on the next page. The sale tax is approximately is 6% entered as .06.

2. Enter the labels and values in the exact cell locations shown in the spreadsheet then format the values as currency.
3. Enter the formulas, as shown in the shaded cells. Tap the Enter key after each formula.
4. Copy the formula to the respective cells by using the fill handle and drag downward.
5. Click inside cell C9 and then click on the down arrow next to the Auto Sum command ‘Σ’ located on the Home tab. Choose the Average function from the list.
6. Select the cell range G3:G5.
7. Repeat the prior steps for cell C10, but this time use the Sum function.
8. Format the cells using the currency format with the dollar sign.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Merchandise</td>
<td>List Price</td>
<td>Discount</td>
<td>Purchase Price</td>
<td>Sales Tax</td>
<td>Total</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>3</td>
<td>Printer</td>
<td>345</td>
<td>185</td>
<td>=C3-D3</td>
<td>=E3*$C$7</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>985</td>
<td>Computer</td>
<td>265</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>395</td>
<td>Monitor</td>
<td>98</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Sales Tax</td>
<td>.06</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Average Cost</td>
<td>=AVG(G3:G5)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Grand Total</td>
<td>=SUM(G3:G5)</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Exercise 2 - Using the PMT Function**

1. Click on Sheet 2.
2. Select the cell range A1:C1 and then click the Merge & Center list arrow in the Alignment group on the Home tab. Select Merge Cells, and then resize the Font if you wish.
3. Select cell range A3:B3 and then Merge Across. Drag the Fill handle downward to repeat the merge process. Stop after cell range A8:B8.
4. Enter the following column labels starting in cell A1.

<table>
<thead>
<tr>
<th>Cell:</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>A1</td>
<td>Payment Calculator</td>
</tr>
<tr>
<td>A3</td>
<td>Sticker Price</td>
</tr>
<tr>
<td>A4</td>
<td>Interest Rate</td>
</tr>
<tr>
<td>A5</td>
<td>Down Payment</td>
</tr>
<tr>
<td>A6</td>
<td>Loan Amount</td>
</tr>
<tr>
<td>A7</td>
<td>Months</td>
</tr>
<tr>
<td>A8</td>
<td>Monthly Payment</td>
</tr>
</tbody>
</table>
5. Select cell range A3:A8 and then click the Bold command.

6. Hold the Ctrl-key down and select cells C3, C5, C6, and C8. Right-click and choose Format Cells | Currency | Decimal places 2 and use the $ sign. Select the fourth format from the negative numbers box to display the debit format.

7. Select cell C4. Right-click and then choose Percentage | Decimal places (2). Click OK. Select cell C7, then right-click and choose Format Cells | Number (no decimal places or comma).

8. In cell C6 type =C3-C5. Press Enter.

9. Select cell C8 and click on the Insert Function button on the Formula Bar. This will open the Function dialog box.

10. Under the heading "Select a function:" select the PMT function. Click OK.

11. Left click and hold down the mouse button on the top part of the dialog box to move the Function Argument box to view the cells in your work area.

12. Click inside the Argument box "Rate" and then click cell C4. Press the forward slash (division) key and then enter 12. The interest rate is computed annual.

13. Click inside the Argument box Nper (number of payments) and then click cell C7 for the number of payments. Click inside the next Argument box Pv. (this stands for the Present value of the loan amount). Type a negative sign (-), then click cell C6. The negative sign before C6 allows us to display a positive number. This play an important role in the next exercise.

You have just used the function box to create a spreadsheet that calculates what your payments would be if you were to purchase a vehicle.

- Enter amounts for the sticker price, down payment, and interest rate.
- Change the number of payments and the amount will change.
- Change the interest rate and amount will increase or decrease.

This formula changes with the data entered.
Using the If Statement

1. In cell A16, type Purchase and then the cell range A16:B16.
2. Click the command Merge & Center list arrow located in the Home tab Alignment Group. Select Merge Across and then click the command Bold.
3. Click inside cell C16 and then the Insert Function button on the formula bar. Select the "IF Function" and then click OK.
4. In the argument box "Logical Test" enter cell reference C8 type \( \leq 250 \).
5. In the Value_if_true box type Deal and then press the Tab key.
   In the Value_if_false box, type No Deal. Click OK.

The decision to purchase will be reflected by one or all of the following factors, (1) amount borrowed, (2) interest rate, (3) down payment, or (4) term of loan.

Using Goal Seek

1. Click the tab "Data," and then the "What If Analysis" list arrow in the Data Tools group. Select Goal Seek.
2. Collapse the "Set cell:" dialog box (click with mouse) to select the cell value to change. For this example, choose Monthly Payment cell C8.
3. Enter a number (goal) in the box "To value:" and then press the tab key.
4. Collapse the "By changing cell:" dialog box and then click in cell C5, Down Payment.
5. Click OK. Cell C5 now reflects the down payment required to attain the desired goal.
6. Click Cancel to revert to the prior payment.

Exercise 3

Calculating the Total Interest Paid & Total Cost of the Loan

1. Select cell range A11:B11. Click the command Merge & Center’s list arrow located in the Home tab Alignment Group. Select Merge Across and then Bold. Next, use the Fill handle to repeat the merge and formatting to the range below.
2. In cells A11 type Total Interest and in A12 type Total Cost.
3. Select cells C11 and C12. Right click on the selected cells and choose *Format Cells | Currency | Decimal* places 2 and use the $ sign.

4. In cell C11 type =C7\*C8-C6. Press the tab key. C12 type =C7\*C8+C5. Press the tab key and then bold the cell range A11:A12.

---

**Creating a Data Table to Analyze a Worksheet**

By creating a data table, you can compare the answers for several different "What if" values.


2. Select and then Merge & Center cell range E1:H1. Type "Table Display of Varying Interest Rates" in the new merged cell.

3. Enter the following column labels starting in cell E2 to H2.

<table>
<thead>
<tr>
<th>Cell</th>
<th>Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>E2</td>
<td>Interest Rate</td>
</tr>
<tr>
<td>F2</td>
<td>Monthly Payment</td>
</tr>
<tr>
<td>G2</td>
<td>Total Interest</td>
</tr>
<tr>
<td>H2</td>
<td>Total Cost</td>
</tr>
</tbody>
</table>

4. Select the cell range E2:H2. Click the *Center* button in the *Alignment* group on the *Home* tab. Next, click the *Format list arrow* and choose "AutoFit Column Width."

5. Click in cell E4 and enter .02 as the first number. Then enter .0225 in cell E5. Select and format both cells as *percentage with two decimal places*.

6. Drag the fill handle to cell E14 and release. Excel incremented each cell by 0.25%.

7. Click in cell F3. Type =C8, tab or press the right arrow key.
   Click in cell G3. Type =C10, tab or press the right arrow key.
   Click in cell H3. Type =C11, press *Enter*.

8. Select the range E3:H14. Click the *What If Analysis list arrow* in the *Data Tools* group on the *Data* tab. Click the command *Data Table*, and then click inside the "Column input cell" box. Type either C4 or click on cell C4. Click *OK*.

9. Excel calculates the results of the three formulas in row 3 for each interest rate in column D and immediately fills corresponding values in the data table.

10. Select the cell range F4:H14 and then format the cells as a number with to decimal places. Click the box to Use a 1000 Separator (,).
**Scenario Summary**

1. Click the **What If Analysis list arrow** in the **Data Tools** group on the **Data tab** and then the command **Scenario Manager**.

2. Click the **Add** button and provide a scenario name. Collapse the dialog box "**Changing Cells**" to select the cells that you would like to change and compare against other data.

   To select non-adjacent cells press the **Ctrl key** and then click on the respective cells.

3. **For example:** To change the Interest Rate and the Loans Term (Months).

   ... **Hold the Ctrl key down** and then click on cells **C4** and **C7**. Click **OK**. The **Scenario Values** dialog box appears.

   ... Enter the new values in the cells referenced by inputting the new Interest Rate and Loan Term.

   ... Click the **Add** button to add another scenario and provide another name to compare the results in either a pivot table or summary sheet. Click **OK** and enter the new values.

4. To display the changes in the current spreadsheet remove the checkmark from "**Prevent Changes.**" Click **OK** and then **Show** to see the changes.

   To display the changes summarized in a **new worksheet** select "**Summary.**" When the Scenario Summary dialog box appears, hold down the **Ctrl key** and select cells **C8, C11,** and **C12** and then click **OK**.

   The scenario worksheet displays as shown below.
Exercise 4 - Sorting Custom Lists

1. Insert a new spreadsheet and then name it Custom Lists. Enter the data below.

2. Starting in cell A2 enter the current date and then press the Enter key.

3. Click back on cell A2 and then place the mouse pointer on the AutoFill handle.

4. Right-click and hold the mouse button down and drag down to cell A13. Release the mouse button to access the AutoFill options menu. Choose Fill Series to populate the cells.

5. Populate the remaining cells using the data listed. Quick tip---Under Department type A, press Enter, B press Enter, and then C press Enter.

6. Select the cell range B2-B4 with the mouse pointer, then right-click and hold the mouse button down. Drag downward to cell B13 and release the mouse button. Choose Copy cells from the shortcut menu.

You may also repeat this step after entering the first three purchases.

<table>
<thead>
<tr>
<th>Date</th>
<th>Department</th>
<th>Purchase</th>
<th>Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>6/12/2011</td>
<td>A</td>
<td>Printing</td>
<td>$44.00</td>
</tr>
<tr>
<td>6/13/2011</td>
<td>B</td>
<td>Software</td>
<td>$124.00</td>
</tr>
<tr>
<td>6/14/2011</td>
<td>C</td>
<td>Computers</td>
<td>$3,200.00</td>
</tr>
<tr>
<td>6/15/2011</td>
<td>C</td>
<td>Software</td>
<td>$500.00</td>
</tr>
<tr>
<td>6/16/2011</td>
<td>C</td>
<td>Printing</td>
<td>$79.00</td>
</tr>
<tr>
<td>6/17/2011</td>
<td>A</td>
<td>Hardware</td>
<td>$300.00</td>
</tr>
<tr>
<td>6/18/2011</td>
<td>A</td>
<td>Printing</td>
<td>$1,200.00</td>
</tr>
<tr>
<td>6/19/2011</td>
<td>C</td>
<td>Hardware</td>
<td>$55.00</td>
</tr>
<tr>
<td>6/20/2011</td>
<td>B</td>
<td>Hardware</td>
<td>$2,400.00</td>
</tr>
<tr>
<td>6/21/2011</td>
<td>B</td>
<td>Printing</td>
<td>$150.00</td>
</tr>
<tr>
<td>6/22/2011</td>
<td>A</td>
<td>Software</td>
<td>$300.00</td>
</tr>
<tr>
<td>6/23/2011</td>
<td>B</td>
<td>Printing</td>
<td>$79.00</td>
</tr>
</tbody>
</table>

7. Select the cell range A1:D1 and then click on the tab File.
8. At the bottom of list, click **Options**. Choose the option **Advanced** and then under the label "General,” click the button **Edit Custom Lists**.

9. In the **Custom Lists dialog box**, verify that the cell reference displayed in the **Import list from cells box** is listed and correct. Click **Import** and then **OK** twice.

10. Click in any cell within your data. Click the **Sort & Filter** list arrow in the **Editing** group on the **Home** tab. Select the command **Custom Sort** and when the **Sort dialog box** opens choose **Sort by: Department** under Column. Select **Custom Lists** under Order.

![Sort dialog box](image)

11. Select the list **Date, Department, Purchase and Cost** and then click **OK**. Click the **Options** button above and set the **Orientation** to “Sort top to bottom.” Click **OK** twice.

12. Click the tab **Data** and then inside one of the list's headers. In the group **Outline**, select the command **Subtotal**. Change the following - **At each change in:** select **Department**. **Use Function:** **Sum** and **Add subtotal to:** check the box **Cost**.

**Note:** you need to check the boxes **Replace current subtotals** and **Summary below data**. Click **OK**.

13. Data should resemble the graphic on the right.

**Note:** Collapsing the minus buttons on the left side hides the detail displayed such as Dates and Purchases.
Recording a Macro

Macro 1 - Auto formatting a worksheet

You should note that in order to save a macro in Microsoft Excel 2010, the workbook must be saved as an Excel Macro-Enable Workbook. In addition, you will need to add the Developer tab to the Ribbon.

How to:
Click on the tab *File* and then *Excel Options*. Choose the category *Customize Ribbon*, then check the tab "Developer".

1. Insert a *New Worksheet* into the Workbook and rename the sheet *Macro1*, then copy and paste the example data from the worksheet labeled “Format” into the new worksheet.

   How to:
   Click the rectangle between *column A1 and row 1* to select the whole worksheet. Click on the command *Copy* and then paste the data into the sheet Macro1.

2. Click on the tab *Developer* and then the command *Record New Macro*. You can either assign a name or use the default. Choose *This Workbook* from the drop down arrow in the dialog box. A description is optional.

3. Select the range *A1:G1* and then click the *Merge & Center list arrow* in the *Alignment group* and select *Merge & Center* on the *Home* tab. Change the font to size *14 Bold* then repeat only the *Merge & Center* for cell range *A2:G2*.

4. Select and *Bold cell range A4:G4* and then cell range *A5:A8*.

5. Select cell range *C5:F8* and then right click | *Format cells*. Select the tab *Number | Category | Number*. Check the box *Decimal places (2)* and *Use 1000 Separator (,)*. 

6. Select the range *C5:G8. Right click | Format cells | Accounting | (show) $ sign, 2 decimal places.*

7. Select and *Bold cell A10*.

8. Select and *Bold cell C10* and right-click and choose *Format cells | Accounting | show $ sign and 2 decimal places.*. Click on the *Border list arrow* in the Font group and add a *Double Bottom Border*.

9. Click the *Stop Macro button* and save the worksheet.

10. Select the entire worksheet as we did in the beginning see Step 1. On the *Home* tab, click the button *Clear, then Clear Formats*. When the formatting has been removed return to the *Developer* tab. Click the command button *Macros* and then run the assigned macro.
Macro 2 - Assign a macro to enter your name and the current date

1. Click the tab Developer and then the command Record New Macro. You can either assign a name or use the default. Choose This Workbook from the drop down arrow in the dialog box. A description is optional.

2. Right-click cell A20 and choose the command Format cells. Select Date as the category and then the Type: "*Wednesday, March 14, 2001" as displayed.

3. Next, type =TODAY() in the newly formatted cell. Press Enter and then click the Stop Macro button.

4. Save the worksheet. On the tab Home click the command button Clear, then Clear Formats. Click in any cell and run the assigned Marco.

Macro 3 - Deleting Blank Rows

1. Enter some date in a work sheet leaving blank rows between the data. Use may use the data in Sheet5 or type your own.

2. Click the tab Developer and then the command Record New Macro. You can either assign a name or use the default. Choose This Workbook from the drop down arrow in the dialog box. A description is optional.

3. Click on the tab Home. Click the Find & Select list arrow in the Editing group on the Home Tab. Select the command Go To Special and then select the option Blanks. Click OK to select the blank rows.

4. Click the Delete list arrow in the group Cells on the Home tab. Select the commands Delete Cells and then Shift cells up to delete all blank rows.

5. Click the Stop Macro button. Use the Undo command to rerun the new created Macro.

Please note that any merged cells are also deleted.